安基网 首页 资讯 安全报 查看内容

NUUO摄像头系统又曝安全漏洞,受影响产品数量超过数十万台

2018-12-3 09:27| 投稿: xiaotiger |来自: 互联网


免责声明:本站系公益性非盈利IT技术普及网,本文由投稿者转载自互联网的公开文章,文末均已注明出处,其内容和图片版权归原网站或作者所有,文中所述不代表本站观点,若有无意侵权或转载不当之处请从网站右下角联系我们处理,谢谢合作!

摘要: 据外媒报道,一个安全研究小组在NUUO摄像头系统NVRMini2中发现了一个安全漏洞,可以被利用来劫持受影响的设备,并篡改监控设备配置和实时监控画面。在本周四,网络安全公司Digital Defense表示,其漏洞研究小组(VRT ...

据外媒报道,一个安全研究小组在NUUO摄像头系统NVRMini2中发现了一个安全漏洞,可以被利用来劫持受影响的设备,并篡改监控设备配置和实时监控画面。

在本周四,网络安全公司Digital Defense表示,其漏洞研究小组(VRT)发现了一个存在于Nuuo NVRmini 2摄像头系统中的漏洞,而该软件正在被全球数十万台监控摄像机使用。

资料显示,该系统被用于该公司的各种监控摄像机产品。它基于Linux,支持NAS存储,可监控多达64个实时视频通道。

从本质上将,该漏洞属于一个无需身份验证的远程缓冲区溢出漏洞。攻击者可以利用该漏洞在具有root权限在系统上执行任意代码。攻击者不仅可以利用该漏洞访问和修改摄像机实时监控画面,还可以更改摄像机的配置和设置。

为了利用此漏洞,攻击者所要做的就是将精心设计的GET请求发送到使用易受攻击固件的服务。只要在数据包中包含的URI长度为351或更大,就会触发堆栈溢出。

“用于保存请求数据的堆栈变量的溢出,会导致覆盖存储的返回地址,攻击者则可以精心设计的有效载荷来实现任意代码执行。”Digital Defense解释说。

问题的根源在于NUUO摄像头系统NVRMini2未能正确清理用户提供的输入,并且缺少URI长度检查。

NVRmini 2固件版本3.9.1及更早的版本均受影响。NUUO迅速回应了研究人员的披露,并发布了一个补丁来解决这个问题。修复程序可以从这里下载。

事实上,早在今年9月份,Tenable的研究人员就发现了NUUO摄像头中的一个远程代码执行漏洞(CVE-2018-1149)。这个被命名为“Peekaboo”的漏洞同样允许攻击者篡改摄像头的视频画面。

本文由 黑客视界 综合网络整理,图片源自网络;转载请注明“转自黑客视界”,并附上链接。

Tag标签: 安全漏洞 摄像头

小编推荐:欲学习电脑技术、系统维护、网络管理、编程开发和安全攻防等高端IT技术,请 点击这里 注册账号,公开课频道价值万元IT培训教程免费学,让您少走弯路、事半功倍,好工作升职加薪!

本文出自:https://www.toutiao.com/a6630395739044315652/

免责声明:本站系公益性非盈利IT技术普及网,本文由投稿者转载自互联网的公开文章,文末均已注明出处,其内容和图片版权归原网站或作者所有,文中所述不代表本站观点,若有无意侵权或转载不当之处请从网站右下角联系我们处理,谢谢合作!


鲜花

握手

雷人

路过

鸡蛋

相关阅读

最新评论

最新

返回顶部